speedo/tacho issue

Post here if you have any problems with any aspect of your Delsol.

Moderators: kenco, SiR_chris, Glovermx, lxstuart, sol'd out, delsolchippy, Del sol 1997, Paulm, solman

speedo/tacho issue

Postby malcrx » Sun Mar 27, 2016 5:52 pm

I have just had a delimiter/converter fitted - thought old converter was the problem. Speedo and tacho still not fixed. Also, as the speedo only goes to 180 kph ( although a sticker says MPH - could that be right) cos if not it was a waste having a delimiter. Car is Sir - Milano. Just had re-spray and bodywork done and it looks nice. Shall I just try an get another head unit ? I am no mechanic or spring chicken - a youthful 64 - but I like cars and a blast in this on sunny days . :? cheers Malc.
malcrx
Newbie
Newbie
Progress to next rank:
16.2%
 
15 years of membership15 years of membership15 years of membership15 years of membership15 years of membership15 years of membership15 years of membership15 years of membership15 years of membership15 years of membership15 years of membership15 years of membership15 years of membership15 years of membership15 years of membership
 
Posts: 17
Joined: Fri Jan 11, 2008 7:33 pm
Location: Chesterfield
Drives: 1992 Sir

Re: speedo/tacho issue

Postby lxstuart » Tue Mar 29, 2016 3:34 pm

Are the speedo/ tacho not working, or reading wrong?
Image

SmithYo wrote:bollocks to wd40.... bita spit normally works a charm ;)

crazyasswhiteboi wrote:was worth the effort, just needed a little wriggling when putting in...


Image Not always SFW
User avatar
lxstuart
DelSolUK Moderator
DelSolUK Moderator
 
15 years of membership15 years of membership15 years of membership15 years of membership15 years of membership15 years of membership15 years of membership15 years of membership15 years of membership15 years of membership15 years of membership15 years of membership15 years of membership15 years of membership15 years of membership
 
Posts: 3107
Joined: Tue Aug 05, 2008 12:04 am
Location: Hertfordshire
Drives: '96 Milano Red SiR, '95 Legend Coupe


Return to Maintenance / Problems / Servicing


cron